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TECH TIP

SENDING Pé DATA TO UNIFIER SCHEDULE SHEET
ORACLE PRIMAVERA UNIFIER

As a Unifier administrator or developer, you may have the following questions in system design:

* How do | connect Unifier and Pé out of the box configurations?e
e How do | create a Schedule Sheet in Unifiere
e How do | Send Pé Schedule Data to the Unifier Schedule Sheet from P62

In today’s topic, we are going to explore these items and give you recommendations on how,
where & when to use these design features in Unifier development and design.

Set Up the Unifier & P6 Connections

In Unifier navigate to Company Workspace > Admin mode > click on Open > On the General
tab > record the Short Name and Authentication Key

Company Work... Lonesdale Place CIP Projects |8 Edit Company - Google Chrome

¢l DRMcnatty Company Workspace @ https://unifierdemo18.mimprojectservices.com/bp/ad mpany/getSiteAd

Fle Edt View Help Address
uDesigner New Find Name:DRMcnatty *

Partner Companies

Data Structure Setup DRMcnatty [Shon Name: DRM ‘J
& Access Control Description: Description
4 User Administration Administrator Contact;j:: Company Administrator Select
¥ Configuration Home Page URL
W Standards & Libraries Help URL Home Page UL
Help URL
i Company Workspace Status Active Inactive
) Templates - Image __Browse.. |
(JPEG/GIF & 500W x 300H pixels) Remove ]
A Programs [ Authentication Key J
& Company Sponsored Projects (Standard) Re-Enter Authentication Key
A Company Sponsored Shells Bid Access URL http://192.168 25.16:7001/pub/bidder
@ Custom Dashboard Bid Management Account Company Administrator Select
Owner: ¢
B System Reports Enable Custom Dashboards
M Configuration Package Management Maximum Limit for UDR records:| 1,000,000 v

Display element for Project / Shell: ® Name Number

These tech tips are offered free of charge in the spirit of sharing knowledge with others. They do not include technical support, should you have a problem with them. We are always interested in how they can be improved, please do not hesitate to email us your comments. These tips have
been thoroughly tested by our ina variety of envir . Please read these tech tips thoroughly and be sure that you understand them before trying to use them. We can not be responsible for issues that develop because of the configuration of your hardware, technical
environment or application of the tech memos. If you are not sure, then we urge you to contact Oracle technical support or your local support consultant for assistance.




SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Navigate to P6 EPPM login & go to the Administration Tab
Within the User interface, navigate to Administration > General

* Enterin your P6 URL, Primavera Unifier URL, Company Short Name from Unifier &
Authentication Code from Unifier > click “Save and Close” when finished.

Dashboards ~  Portfolios ~  Projects ~  Resources Approvals Reports. I Administration

Application Settings ~ Enterprise Data  Scheduled Services  User Administration  User Interface Views

Application Settings

Audt General
Consent Notice Starting Day of Week Document Management
Data Limits First day of week for calendars Enter the P8 URL to enable users to view content repository documents in the P8 Professional module
Sunday -

Eamed Value PEURL I
Eventing Activity Duration

Default duration for new activities *

Securty Policy
] 5.0d -
ID Lengths
Codes Unifier

Reports T

Code separator character * Primavera Unifier URL
Services
Timesheets

Company Short Name
Time Periods

haracters iong

Industry Selection
Industry to use for terminology and default calculation settings in the P6 Professional module

P6 Professional Applications

Password Policy Run in Secure Global D

¥ Enable

In P6 EPPM go to the Projects Tab

Within the User Pé EPS, navigate to Your Pé Project > General Tab > and Copy your Unique
Project ID

Dashboards ~  Portiolios ~ [E0SS""Sll Resources  Approvals Reports  Administration

EPS  Activites  TeamUsage  Assignments  Issues Documents  Risks

Enterprise Project Structure
Acions ~  Open ~ Views Default View - F Y X
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D" Start Data Date Project Owner _ Ma}
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n
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i KENAVE ! Ene
im PONDVIA 2
i FRESTREN State Route 180 Passageway ar n
| & KANSAVE  Kansas Avenue Grade Separation ] 01-Aug-18 20-May-19 En
0 | © &Templates Project Templates £nt
©  General Budget Log Codes Funding ssues Notebooks Risks
Details Planned Dates
Project 1D * Project Status * Anticipated Start
KANSAVE J|[ Active - E
Project Name * Location Anticipated Finish
Kansas Avenue Grade Separation | u ﬂ
Responsible Manager * Checked Out By Project Planned Start *
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

In Unifier Navigate to Your Project > User Mode > click on Details > General tab > and input
your Pé Project ID from Project ID in P6 > click Apply & Ok

>

Garces Highwa... _ Pond Road Viad...

Construction Pac >  Kansas Avenue

Tulare Street U...

Fargo Avenue ...

American Aven...

@& demounifier.mImprojectservices.com/bp/shell/propert i fals uref=u @ fwDashboard My Dashboard
General Curmrency Integration
Project Details
General
Project Name:|Kansas Avenue Grade Separati * Status:| Active v o*
Project Number: P-0015 Administrator:[Kevin Hicks Select *
IPG Project ID: KANSAVE l Hierarchy Path:)/CENTRAL VAL Select. | *
Sections Phase |-/ Fresno - Bakersfield v Sections Phase II:[ _Sglect- v
Project Start Date:[0g/01/2018 ] * Project End Date: |
Estimated Budget 0.00 Schedule Type:|Cost Loaded
Description
Description
Aply | oK cancel |

_+.

In P6 EPPM > go to the

Dashboards ~ Portfolios + Projects ~ Resources Approvals Reports Administi
EPS Activities Team Usage Assignments Issues Documents Risks
Enterprise Project Structure
Actions ¥  Open v Views Default View “ X s
ID* Name * Data Date
im GAMA Project Gama 04-Jan-21
i GAMA - B1  Project Gama - Base Cost Loaded 20-May-19
im DELTA Project Delta 20-May-19
i HAYWARD  Hayward Maintenance Complex 20-May-19
W TRANSBAY  Transbay Corridor Core Capacity 20-May
i AMERAVE  American Avenue Grade Separation 01-Aug-19
i KENAVE Kent Avenue Grade Separation
im PONDVIA Pond Road Viaduct 01-Nov-18
W FRESTREN  Fresno Trench & State Route 180 Passageway | 02-Jan-18 A 01-Aug-19
O @ KANSAVE  Kansas Avenue Grade Separation |o1 -Aug-18 20-May-19
Project Templates
Add Pr
Add Project Template
Clost tlog Codes Funding ssues Notebooks Risks
All
Planned Dates
Project Status * Anticipated Start
| [ Active - | \

Delete

Location

leparation ‘ Searc

Checked Out By
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Anticipated Finis|

Project Planned

01-Aug-18

Projects Tab > Navigate to your “Project” > Select Set Project
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Sending the Pé Schedule Data to Unifier

** Note This Infegration assumes you have beforehand created in your Unifier Project a
Schedule Sheet and a Data Mapping Sheet;

** If you have not completed this, jump to the next steps Under > Heading: Creating the
Unifier Schedule Sheet and its Data Mapping Sheet

Go to the Integrations Tab > Click Unifier > Select Link Project to a Primavera Unifier Project >
Select your Project Name > select your Schedule Sheet > Select your Data Mapping > click
the Box “Delete activities no Longer in the P6 Schedule from Primavera Unifier” > Click OK

Project Preferences of Kansas Avenue Grade Separation @ X

General Analytics & Services Calculations Integrations Team Member

Configure the settings for Unifier integration.
Schedule Sheet Integration Summary Sheet Integration
| @) Link project to a Primavera Unifier project Schedule Type

Cost Loaded v

Project Name
Kansas Avenue Grade Separation E
Synchronize WBS Hierarchy
Schedule Sheet Complete -
‘ Kansas P6 Schedule u

Data Mapping
P6 Data Mapping u

¢} Delete activities no longer in the P6 Schedule from Primavera
Unifier
-

Only send activities with CBS codes assigned

coe | (o
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Next in P6 EPPM > With your “Project” Open > go to the Activities Tab > Actions > Exchange

Data > Send to Schedule Sheet

Dashboards ~ Portfolios ~ Projects ~ EESCERII{EEN Approvals Reports Administration

EPS  Activities TeamUsage  Assignments Issues Documents  Risks

Activities of Kansas Avenue Grade Separation

Schedule Views High Speed Rail v B B * v Y
efine Baselines
ID/Code * | CBS
Apply Actuals =
o im KANS de Separation

fg 0101 Check Schedule imental
l'. 0
‘ : I Exchange Data l o
g 03 i 2 I and nr -
T 01 : A 0 r
01 ;
ﬁ 03 ( e =

< B X

WBS Code
KANSAVE
01 01750
0101100

Click > OK

Send To Schedule Sheet X

This service request will be processed at the interval
determined by your administrator. To view the status
of the service after it is processed, select View Service
Status on the User menu.

Do not show again E
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Under Your Username > Select View Service Status > to see the completed Service > Click
Close

My Preferences

‘ View Service Status. ‘

I User Sessions

View Log..  C n 2 ©  Search Q

Service Status i O Initiator Projects

[ Send To Schedule Sheet Completed 15-Aug-19 GMT-0... 15-Aug-19 GMT-0... Kevin Hicks KANSAVE - Kansas Avenue Grade Separ... |
T

Logout

Next Navigate Back to Primavera Unifier > go to your “Project” > Schedule Sheets > Open
and view your data and Verify your Project Schedule Sheet has been Updated

ORACLE" Primavera Unifier (Development)

W & < ompany Work... Programs Garces Highwa... _ Pond Road Viad... Tulare Street U

A Kansas Avenue Grade Separ.... CENTRAL VALLE >  Construction Pac > Kansas Avenue
A ANers File Edit View Help
& Mailbox G2 P New @3Copy v (& Open [ Properties & Permission g° Comments & Find > Refresh ~
Task Manager 521 Schedule Sheets - Current View: Active
© Information &3] 1 item(s) Page |1 of 1
m Document Manager P 2 Title ~ Created Date Creator Status [ Last Update Structure
® Financial Transactions Y File Edt View 08/15/2019 Unlocked
@y Change Management (4>) Save Add ~ ¢ Delete B Indent E Outdent Gantt B Progress m (
BA Financial Reporting £ Kansas P6 Schedule T
Mg Document Management 3] [ M
f8) Schedule Manager o Id Activity Name P6 Activity Start date Finish dal ;
Schedule Sheets 1 B Planning and Environmental 05152019 | 0515208 | | =
Activity Sheet 2 Begin Planning & Environmental | PE-1000 05/15/2019 05/15/20
Communication & Followup 3 Environmental Impact Study PE-1010 05242019 09/13720
Dnook Reporting 4 aft EIS/EL PE-1020 091092019 | 01/31720,
psicctciossa 5 Review / Approve Final EISEIR | PE-1030 01272020 | 0815720
REPEE 6 Planning and Environmental Com VPE71040 05/15/2020 05/15/20;

7 =l-Design Engineering gi ig Egig i% ﬁs ig
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Creating the Unifier Schedule Sheet & Its Data Mapping

Follow these next Steps > In Unifier navigate to Your Project > User Mode > click on Schedule
Sheets > New > On General Tab enter in your Schedule Title > Set Status to Active > Select a
Schedule Start Date > On Options Tab - Select Activity Progress requires and Actual Start
Date > On Schedule Tab - Select Enable scheduled refresh > Click OK

il ‘& < ompany Work... Programs Garces Highwa.. Pond Road Viad... Tulare Street U... Fargo Avenue ... Americ
A Kansas Avenue Grade Separ. CENTRAL VALLE > Construction Pac > Kansas Avenue
A Nerts File Edt View Help [ Schedlule Sheet Properties - Google Chrome = O
Mailbox (2] Copy ~ @Open [AP & demounifiermimprojectservices.com/ schedule_mode. Q
Task Manager 20 schedule Sheets - Current View: Active General PE—— Er— OpiioTs e
Information 1 Item(s)
o & | Overview
M Document Manager S} © Tite ~ Cre 1
= | Schedule Title: Kansas P6 Schedule | *
Kansas P6 Schedule 07/ —
Documents Description:
Recycle Bin
Financial Transactions
Master Schedule: Create as master schedule sheet
Change Management Status: ® Active  Inactive
Financial Reporting Auto-control: - On ® Off
Auto-Schedule: ©
Document Management uto-Schedule: @ Enable ' Disable
Calendar:|  Project/Shell Calendar v
Schedule Manager Schedule Start Date: © Manual  From Shell Attribute
Schedule Sheets 05/15/2019 =R
AT Notify users and/or groups on errors: Select
‘Communication & Followup Permission: Enforce Activity Level Permissions by Group
Default Group:| -Select- v
©Ongoing Reporting
Project Closeout
Reports OK Cancel
—

General Gantt Chart Tracking Gantt Options

Options

Auto update activity status based on Actual Start / Finish Dates

Y

Activity Progress requires an Actual Start date |

Enforce Activity 100% Complete against Actual Finish date
Auto-Update % Complete to 100% after entering Actual Finish date

General Gantt Chart Tracking Gantt Schedule

Scheduled Refresh

I ¥ Enable scheduled refresh I

Frequency

®' Daily
Weekly, end of day [Sunday  v|

Monthly l | 3
Quarterly
Yearly

Range of Recurrence

®' No end date
End by j i
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Double Click on your Created Schedule Sheet > Click File > Data Mapping

M) ) Company Work... Programs Garces Highwa... | Kansas Avenue Pond Road Viad... Garces H
A Kansas Avenue Grade Separ... CENTRAL VALLE... > Construction Pac >  Kansas Avenue
A Aerts File Edit View Help [ < i\ coooie Chrome
& Mailbox FiNew BCopy + Gl — - : -
& 2 L @& demounifier.mimprojectservices.com/bp/sch/openSCHView?id=13&_ uref=uuu287462
Task Manager Schedule Sheets - Current ‘ Edit View
@ information 1 ltem(s) Save Indent Outdent | Gantt [ Progress [l
mm Document Manager Y O Title |
— Open Snapshot
o ; Kansas P6 Schedule |
& Financial Transactions Save As Snapshot
B Change Management Brint P6 Activity ... Start date Finish date
rin
RX Financial Reporting r
Export > 05/15/2019 05/15/2020
g Document Management o
Import » |ental PE-1000 05/15/2019 05/15/2019
(@) Schedule Manager =
Properties [ PE-1010 05/24/2019 09/13/2019
Schedule Sheets L o
Restrictions PE-1020 09/09/2019 01/31/2020
Activity Sheet L A
VLY EEE Data Mapping
. [EIR PE-1030 01/27/2020 05/15/2020
Communication & Followup i
Onaoina Resort Setup Scope Management | Com... | PE-1040 05/15/2020 05/15/2020
ngoing Reporti
YLy ~  Budget and Progress Setup  » 05/18/2020 1212512020
/
Project Closeout | ) )
Close Window DE-2000 05/18/2020 05/18/2020
Reports
9 30% Design Engineering DE-2010 05/22/2020 07/17/2020
10 60% Design Engineering DE-2020 07/13/2020 09/04/2020
" 90% Design Engineering DE-2030 09/07/2020 10/30/2020
12 Final Review and Approval of De... | DE-2040 11/02/2020 12/25/2020

Click on Add > Name the Mapping File “Pé Data Mapping”

Data Mappings I
Name . Default Mapping
P6 Data Mapping v J
Add__ Modify. |  Remove |
OK | Cancel I I
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

On the Activity Tab > Add these following Mapping Elements In the CVS Header and XML
Element Columns

** Pay close attentfion to the Case Sensitive text and word spacing

General

Resources Options

Column & CSV Header XML Element

Activity Name Activity Name Name

Activity Percent Activity Percent PercentComplete

Actual Finish Date Actual Finish Date ActualFinishDate

Actual Start Date Actual Start Date ActualStartDate

Duration Duration PlannedDuration

Finish date Finish date FinishDate

P6 Activity Number P6 Activity Number Id

Start date Start date StartDate

Add... Remove Export... I Import... I

ok |  cancel |

On Options Tab - Select Overwrite Existing Schedule and Activities Box in both places > Click
oK

General Resources Options

XML Import

Options: Merge into existing schedule

vifi d from source schedule
® Overwrite existing schedule
¥ Activities

O Activity Dependencies
Activity Calendar
Resource Assignments
CBS Codes

Number of Levels:
Suffix Mask:

Data Elements:

Constant
Data Element

1 Activity Dependencies
Resource Assignments
CBS Codes

-Select One- v

XML Export

Data Elements:

ok || cancel
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

Next Open your Pé Schedule Sheet > Click Edit > Select Columns > Click New >

File @View
A Kansas Avenue Gr{ - -
Se Add » lindent Outdent | Gantt [ Progress [fll] Columns @ Find @ ZoomIn (= ZoomOut 4 F
A Aerts Delete
. Kans
B4 Mailbox Indent
May 5, 2019 May 12, 2019
Task Manager jg  outdent PG Activity . | Start date Finish date
T‘F‘S‘S‘M’T‘W‘T‘F s‘
© Information Copy
= ~ :
M Document Manage: ! Cut @ Open [ AuditLog
. . i 2 Paste PE Columns
S =
® Financial Transactid Name Order  Display Mode  Data Source
@y Change Managem I PE 'P6 Activity Number 1 Show USMACHVNmbITB120
Start date 2 Show uuu_start
5 q 5 4 Copy Column Data PE =
R Financial Reporting Finish date 3 Show uuu_finish
] 5 Baseline PE || Actual Start Date 4 Show uuu_actual_start_date
s Linked Business Process b —= Actual Finish Date 5 Show uuu_actual_finish_date,
(@) Schedule Manager - Activity Percent 6 Show uuu_act_pct_complete
Schedule Sheet- 4 Comments Duration 7 Show uuu_duration
Activity Sheet 8 Update > DE
Communication & 9 30% Design Engineering DE
Ongoing Reporting [V} 60% Design Engineering DE
Project Closeout 11 90% Design Engineering DE
Move Up (Left Move Down (Right
Reports 12 Final Review and Approval of De... | DE Rl I g )I
13 Design Engineering. Complete DE &I I
S —

Select Your Column Data Source from the Dropdown Menu > Set the Column Position After
> All columns in the Screen Shot > when finished click OK

W
]5 . . E Name: -Select One-
Save EMAdd ~ ¢ Delete [F Indent EF Outdent antt g Progress Columns
ca &8 & e Prog m Data Source -Select One- vi*
demounif Iry G Data Entry Activity Constraint
demounifier.m cts
CACOTORR = ‘ Entry Method Activity Latest Progress As Of
[HNew (& Open Audit Log Activity Percent
‘ Activity Status
Columns | Actual
Name Order  Display Mode  Data Source Actual Finish Date
Actiity Number I Show USMACTIVNMDI T Actual Start Date
Start date 2 Show uuu_start Assigned Resources
Finish date 3 Show uwuu_finish Auto-update Activity Data
Actual Start Date 4 Show uuu_actual_start_date “‘é"e, m Ouration
N » ) Data Format Baselne Finish
Actual Finesh Date 5 Show uuu_actual_fiush_date Baseline Start
Activity Percent 6 Show uuu_act_pct_complete Show as percentage Baseline Total Cost
Duration 7 Show uuu_duration Decimal Places. Calendar
Summe Early finish date
id Early Start date
Display Earmed Amount
Earned Progress
Date rollup Estimated Duration v
Number rollup: * Total
Average
Move Up (Left) ] Move Down (Right) I Weighted Average based on
Select v
Close Additional
T R e ——— T T . T
12 Final Review and Aporoval of De . | DE-2040 1110212020 12252020 || Display Mode ® Show Hido
13 Desion Engineering Complete DE-2050 1272512020 12/25/2020 ICc(umn Position After [Activity Name i e I
14 E 0910772020 09/032021
15 09107/2020 0900772020
16 09/07/2020 12/25/2020
17 12/28 0 42021
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SENDING Pé DATA TO UNIFIER SCHEDULE SHEET

When you return to the Schedule Sheet, you will now see your columns mapped to P6 data
in your Unifier Schedule Sheet.

File Edit View

Wil & < ompany Work. save [ Add ~ ¢ Delete Indent Outdent  Gantt [ Progress Columns @ Find @ ZoomIn (=) Zoom Out 4 Focus Close Window
A Kansas Avenue Grade. .
A Aerts Kansas P6 Schedule
&4 Mailbox () Id Activity Name P6 Activity Number Start date Finish date Actual Start Date | Actual Finish Date | Activity Percent Duration
Task Manager (<3}
° N @ 1 [El-Planning_and Environmental 05/15/2019 05/15/2020 367
; DR V— @ 2 Begin Planning & Environmental PE-1000 05/15/2019 05/15/2019 0 1
@ Financial Transa:ons ® 3 Environmental Impact Study. . PE-1010 05/24/2019 09/13/2019 . 0 81
@y Change Management ) 4 Draft EIS/EIR PE-1020 09/09/2019 01/31/2020 0 105
KA Financial Reporting ) 5 Review / Approve Final EIS/EIR PE-1030 01/27/2020 05/15/2020 0 80
Mg Document Managem... @ 6 Planning and Environmental Com...| PE-1040 05/15/2020 05/15/2020 0 1
@ Schedule Manager e 7 [=1-Design Engineering 05/18/2020 12/25/2020 222
Schedule Sheets 8 Begin Design Engineering DE-2000 05/18/2020 05/18/2020 0 1
Activity Sheet 9 30% Design Engineering DE-2010 051222020 07/17/2020 0 41
Communication & Fo... D 10 60% Design Engineering DE-2020 07/13/2020 09/04/2020 0 40
0 Ongoing Reporting @ " 90% Design Engineering DE-2030 09/07/2020 10/30/2020 0 40
Project Closeout (53] 12 Final Review and Approval of De... | DE-2040 11/02/2020 12/25/2020 0 40
Reports &) 13 Design Engineering Complete . DE-2050 12/25/2020 12/25/2020 . 0 1
14  [E-Right of Way, 09/07/2020 09/03/2021 362
15 Begin Right of Way procurement RW-3000 09/07/2020 09/07/2020 0 1
16 Establish ROW RW-3010 09/07/2020 12/25/2020 0 80

Summary

Using Unifier’s out-of-the-box built in integration to Pé is one of the most efficient ways to
manage and provide schedule visibility fo users working in Unifier projects with Pé schedule
components/needs. Schedule data being updated in Pé can be transferred to Unifier as
long as you understand some of the aspects of its use and how it impacts your projects.
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