AUGUST 2019
ORACLE PRIMAVERA UNIFIER
SENDING P6 DATA TO UNIFIER SCHEDULE SHEET

As a Unifier administrator or developer, you may have the following questions in system design:

* How do | connect Unifier and P6 out of the box configurations?
* How do | create a Schedule Sheet in Unifier?
* How do | Send P6 Schedule Data to the Unifier Schedule Sheet from P6?

In today’s topic, we are going to explore these items and give you recommendations on how, where &

when to use these design features in Unifier development and design.

Set Up the Unifier & P6 Connections

In Unifier navigate to Company Workspace > Admin mode > click on Open > On the General tab >

record the Short Name and Authentication Key

Company Work... Lonesdale Place CIP Projects [8] &dit Company - Google Chrome
¢l DRMcnatty O a Worksnace @& https://unifierdemo18.mImprojectservices.com/bp/ad mpany/q Ad

uDesigner New Find Name:DRMcnatty
Data Structure Setup DRMcnatty | Short Name DRM
Access Control Description: Description
User Administration Administrator Contact Name:Company Administrator Select
Configuration Home Page URL DUNS
~ Help URL Home Page URL

landards & Libraries Help URL
Company Workspace Status Active Inactive
Templates ¢ Image B'°‘~4‘.I

(JPEG/GIF & 500W x 300H pixels) Remove
AEGIIE I Authentication Key ]
Company Sponsored Projects (Standard) Re-Enter Authentication Key
Company Sponsored Shells . Bid Access URL http//192 168 25.16:7001/pub/bidder
o Dot Bid Management Account Company Administrator Select
Owner: ¢
System Reports Enable Custom Dashboards
Configuration Package Management € Maximum Limit for UDR records:| 1,000,000 v
Display element for Project / Shell: ® Name Number
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Navigate to P6 EPPM login & go to the Administration Tab

Within the User interface, navigate to Administration > General

* Enter in your P6 URL, Primavera Unifier URL, Company Short Name from Unifier &
Authentication Code from Unifier > click “Save and Close” when finished.

Dashboards ~  Portfolios = Projects ~  Resources  Approvals  Reports

I Administration

Application Settings  Enterprise Data  Scheduled Services

Application Settings

Audit General

Consent Notice Starting Day of Week

Data Limits First day of week for calendars
Suncay -
Eamed Value

Eventing Activity Duration

Default duration for new activities *

5.0d

1D Lengths

Codes
Reports

Code separator character *
Services
Timesheets naracter.
to display code values

Time Periods

Industry Selection
Industry to use for terminology and default calculation settings in the P6 Professional module
Password Policy

@ Enable

Document Management

Enter the P6 URL to enable users to view content repository documents in the P6 Professional module

6 URL l

Security Policy

Unifier

l Primavera Unifier URL ]

Company Short Name

P6 Professional Applications

Run in Secure Global Desktop environment

In P6 EPPM go to the Projects Tab

Within the User P6 EPS, navigate to Your P6 Project > General Tab > and Copy your Unique Project

ID

E—
Dashboards ~  Portiolios ~ 0SSl Resources  Approvals Reports  Administration
EPS Activities Team Usage Assignments Issues Documents Risks

Enterprise Project Structure

Actions ¥ Open v Views D

Project Name * Location

Kar venue Grade Separation ‘

Responsible Manager * Checked Out By

Energy
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[ KANSAVE  Kansas Avenue Grade Scpnntlon ] 01-Aug-18 20-May-19 Eny
o A Templates Project Template ot
© General  Budgetlog  Codes  Funding  lssues  Notebooks Risks
Details Planned Dates
Project 1D * Project Status * Anticipated Start
AVE ‘ Active - ‘ D

Anticipated Finish

Project Planned Start *
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In Unifier Navigate to Your Project > User Mode > click on Details > General tab > and input your P6

Project ID from Project ID in P6 > click

Apply & Ok

Garces Highwa... Pond Road Viad... Tulare Street U... Fargo Avenue ... American Aven... —+-
>  Construction Pac >  Kansas Avenue
=
& demounifier.mImprojectservices.com/bp/shell/proper i eshlog=fa Y ) jectld uref=u... @ L Dashboard My Dashboard
General Currency Options Links Calendar Integration
Project Details
General
Project Name: [Kansas Avenue Grade Separati * Status:| Active v|*
Project Number: P-0015 Administrator:[Kevin Hicks Select *
P6 Project ID: KANSAVE Hierarchy Path:/CENTRAL VAL Select.. | *
Sections Phase |-/ Fresno - Bakersfield v Sections Phase Il:[ _Sglect- v
Project Start Date:[0g/01/2018 ) * Project End Date: e
Estimated Budget 0.00 Schedule Type:|Cost Loaded
Description
Description
l Apply | ok I cancel |

In P6 EPPM > go to the Projects Tab >

Navigate to your “Project” > Select Set Project Preferences

Dashboards ~ Portfolios ~ Projects ~ Resources Approvals Reports Administ|
EPS  Activities Team Usage  Assignments  Issues  Documents  Risks
Enterprise Project Structure
Actions ¥ Open v Views Default View Yy & X
ID* Name * Data Date
im GAMA Project Gama 9A 04-Jan-21
i GAMA -B1  Project Gama - Base Cost Loaded
im DELTA Project Delta
W HAYWARD  Hayward Maintenance Complex
W TRANSBAY  Transbay Corridor Core Capacity y
i AMERAVE  American Avenue Grade Separation 08-Jan-18 A
i KENAVE Kent Avenue Grade Separation 01-Jan-18 A
i PONDVIA  Pond Road Viaduct 01-Ne
i FRESTREN  Fresno Trench & State Route 180 Passageway | 02-Jan-18 A 01-Aug-19
O @ KANSAVE  Kansas Avenue Grade Separation Jo1-Aug-18 20-May-19
Project Templates
Add Project
Add Project Template
tlog Codes  Funding ssues  Notebooks  Risks

Delete
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Project Status *

Planned Dates

Anticipated Start]

‘ Active

Location
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Checked Out By

Project Planned

01-Aug-18

Page 3



Sending the P6 Schedule Data to Unifier

** Note This Integration assumes you have beforehand created in your Unifier Project a Schedule
Sheet and a Data Mapping Sheet;

** If you have not completed this, jump to the next steps Under > Heading: Creating the Unifier
Schedule Sheet and its Data Mapping Sheet

Go to the Integrations Tab > Click Unifier > Select Link Project to a Primavera Unifier Project >
Select your Project Name > select your Schedule Sheet > Select your Data Mapping > click the Box
“Delete activities no Longer in the P6 Schedule from Primavera Unifier” > Click OK

Project Preferences of Kansas Avenue Grade Separation ® X

General Analytics & Services Calculations Integrations Team Member

Configure the settings for Unifier integration.

Schedule Sheet Integration Summary Sheet Integration

I @ Link project to a Primavera Unifier project Schedule Type

t Loaded -

_Project Name

[ Kansas Avenue Grade Separation

Synchronize WBS Hierarchy

Schedule Sheet Complete -
‘ Kansas P6 Schedule u

Data Mapping

P6 Data Mapping u‘

@ Delete activities no longer in the P6 Schedule from Primavera

Unifier

Only send activities with CBS codes assigned
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Next in P6 EPPM > With your “Project” Open > go to the Activities Tab > Actions > Exchange Data >
Send to Schedule Sheet

Dashboards ~ Portfolios ~ Projects ~ EESCERII{EEN Approvals Reports Administration

EPS  Activities TeamUsage  Assignments Issues Documents  Risks

Activities of Kansas Avenue Grade Separation

Schedule Views High Speed Rail A B -3 53 N/ P P
Define Baselines
ID/Code * | CBS WBS Code
Apply Actuals ~
O im KANS de Separation KANSAVE
Roio Check Schedule imental 0101750
r.j‘ 01 01 01100
vy 01700
T 0 I Exchange Data l [T Cap Artisis A Acclnnenante fnr F\VAL :
Tg 03 0: - I~ Get Activities and Assignments for EVN 03 03400
a0 : A D r 010176
‘ 01 I )1 01500
% ‘] : ‘: = IME e 2 N300

Open Dependent Projects -
| '~TJ Send to Schedule Sheet I
Publish Projects

Click > OK

Send To Schedule Sheet X

This service request will be processed at the interval
determined by your administrator. To view the status

of the service after it is processed, select View Service

Status on the User menu.

Do not show again g
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Under Your Username > Select View Service Status > to see the completed Service > Click Close

My Preferences

‘ View Service Status. ‘

I User Sessions

W C S — ai
View Log..  C n % | & | Searc Q Logout
Service. Status. C Initiator Projects. .
[ Send To Schedule Sheet Completed 15-Aug-19 GMT-0... 15-Aug-19 GMT-0... Kevin Hicks KANSAVE - Kansas Avenue Grade Separ... J
T

Next Navigate Back to Primavera Unifier > go to your “Project” > Schedule Sheets > Open and view
your data and Verify your Project Schedule Sheet has been Updated

ORACLE" Primavera
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Task Manager
Information

Document Manager
Financial Transactions
Change Management

Financial Reporting
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Document Management
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Schedule Manager

(0)

Schedule Sheets
Activity Sheet
Communication & Followup
Ongoing Reporting
Project Closeout

Reports

& DR/McNatty
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Unifier (Development)

Id

File
[ New

Schedule Sheets - Current View: Active

File

Programs

CENTRAL VALLE >

Edit

1 Item(s)

O Title

Edit

Save

= Planning.ang

B3 Copy ~ & Open

View Help

Garces Highwa...

Construction Pac

[}t Properties

> Kansas Avenue

~ Created Date

View

Kansas P6 Schedule

Activity Name

Begin Planning & Environmental

Environmental Impact Study.
raft EIS/E|
Approve Final EIS/EIR

Review

Planning and Environmental Com

=-Design Engineering

BEJAdd ~ ¢ Delete [ indent [E Outdent

P6 Activity

PE-1000
PE-1010
PE-1020

PE-1030

PE-1040

e ——

Pond Road Viad...

Tulare Street U

O Refresh ~

Page (1 of 1

Last Update
08/15/2019

Structure
Unlocked

& Permission @@ Comments & Find
Creator Status

Gantt [ Progress [fff ¢

T

M

Start date Finish daj
T

-
05/15/2019 05/15/20:
05/152019 05/1520
05/24/2019 09/13/20
09/09/2019 01/31/20.
01/27/2020 05/15/20!
05/15/2020 05/15/20;
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Creating the Unifier Schedule Sheet & Its Data Mapping

Follow these next Steps > In Unifier navigate to Your Project > User Mode > click on Schedule
Sheets > New > On General Tab enter in your Schedule Title > Set Status to Active > Select a
Schedule Start Date > On Options Tab - Select Activity Progress requires and Actual Start Date > On
Schedule Tab - Select Enable scheduled refresh > Click OK

\.l.l.l A < ompany Work... Programs Garces Highwa... Pond Road Viad... Tulare Street U... Fargo Avenue ... Americ}
P TG EE Nl CENTRAL VALLE. . > Construction Pac. > Kansas Avenue
A Herts File Edit View Help [8 schedule Sheet Properties - Google Chrome - @O
= Mailbox [ New |Bacopy ~ @B open AP & demounifiermimprojectservices.com/bp/sch/addedit?id=13amewsheet=falseficopyOrimport=falseéischedule mode... @
Task Manager Schedule Sheets - Current View: Active TR ontiChar E——
© Information 1 Item(s) i
. Overview
W Document Manager 2 | Title - Cr¢
gel (S) | | Schedule Title:[Kansas P6 Schedule | *
Kansas P6 Schedule 07

Documents Description:

Recycle Bin
® Financial Transactions

Master Schedule: || Create as master schedule sheet
By Change Management Status: ® Active  Inactive
RE Financial Reporting Auto-control:  on © off
Auto- le: ®
By Document Management uto-Schedule: Enable Disable
Calendar: Project/Shell Calendar v

[@ Schedule Manager Schedule Start Date: ® Manual  From Shell Attribute

Schedule Sheets 05/15/2019 &

Activity Sheet Notify users and/or groups on errors: Select

P
€3 Communication & Followup ermission: [ Enforce Activity Level Permissions by Group
Default Group:| -Select- M
Ongoing Reporting
m Project Closeout
B Reports OK Cancel
.

General Gantt Chart Tracking Gantt Options

Options

Auto update activity status based on Actual Start / Finish Dates

| v Activity Progress requires an Actual Start date |

Enforce Activity 100% Complete against Actual Finish date
Auto-Update % Complete to 100% after entering Actual Finish date

General Gantt Chart Tracking Gantt Options Schedule

Scheduled Refresh

I ¥ Enable scheduled refresh I

Frequency
®' Daily
Weekly, end of day v Sunday v \
Monthly i
Quarterly
Yearly

Range of Recurrence

®' No end date
End by ]
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Double Click on your Created Schedule Sheet > Click File > Data Mapping

[l &  Company Work.
Alerts

Mailbox

Task Manager

Information

Document Manager
Financial Transactions
Change Management
Financial Reporting
Document Management

Schedule Manager

A
A
]
i ]
-
®
=]
[V
)
@

Schedule Sheets
Activity Sheet
Communication & Followup
Ongoing Reporting
Project Closeout

Reports

. Programs

Kansas Avenue Grade Separ...

CENTRAL VALLE... > Construction Pac > Kansas Avenue

File Edit View Help B s
EHNew BEzCopy + &

Schedule Sheets - Current ‘ Edit View

edule Manager - Google Chrome

Garces Highwa... Pond Road Viad...

@& demounifiermimprojectservices.com/bp/sch/openSCHView?id=138&__uref=uuu28746]

Garces H

Click on Add > Name the Mapping File “P6 Data Mapping”

1 ltem(s) Save Indent Outdent | Gantt [ Progress [l
O it |
— Open Snapshot
Kansas P6 Schedule |

Save As Snapshot

P6 Activity ... Start date Finish date
Print
Export > 05/15/2019 05/15/2020
Import » lental | PE-1000 05/15/2019 05/15/2019
Properties PE-1010 05/24/2019 09/13/2019
Restrictions PE-1020 09/09/2019 01/31/2020
| Data Mapping
/EIR PE-1030 01/27/2020 05/15/2020
Setup Scope Management | Com...| PE-1040 05/15/2020 05/15/2020
" Budget and Progress Setup  »

05/18/2020 12/25/2020
Close Window DE-2000 05/18/2020 05/18/2020
9 30% Design Engineering DE-2010 05/22/2020 07/17/2020
10 60% Design Engineering DE-2020 07/13/2020 09/04/2020
" 90% Design Engineering DE-2030 09/07/2020 10/30/2020
12 Final Review and Approval of De... | DE-2040 11/02/2020 12/25/2020

Data Mappings
Name . Default Mapping
' P6 Data Mapping v
Add.. Modify.. |  Remove |

OK

Cancel |
B

:
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On the Activity Tab > Add these following Mapping Elements In the CVS Header and XML Element

Columns

** Pay close attention to the Case Sensitive text and word spacing

General

Resources Options
Column a CSV Header XML Element
Activity Name Activity Name Name
Activity Percent Activity Percent PercentComplete
Actual Finish Date Actual Finish Date ActualFinishDate
Actual Start Date Actual Start Date ActualStartDate
Duration Duration PlannedDuration
Finish date Finish date FinishDate
P6 Activity Number P6 Activity Number Id
Start date Start date StartDate

Add... Remove Export...
OK I Cancel I

On Options Tab - Select Overwrite Existing Schedule and Activities Box in both places > Click OK

RIMcNatty
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oo | oy | Resowoos |
XML Import
Options:

Data Elements:

XML Export

Data Elements:

Options

Merge into existing schedule

iviti d from source schedule
® QOverwrite existing schedule
¥ Activities

O Activity Dependencies
Activity Calendar
Resource Assignments
CBS Codes

Number of Levels:
Suffix Mask:

Constant
Data Element

O Activity Dependencies
Resource Assignments
CBS Codes

-Select One- M

ok || cancel
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Next Open your P6 Schedule Sheet > Click Edit > Select Columns > Click New >

File
Kansas Avenue Gr4

-

P8 - -
Se Add » lIndent Outdent | Gantt [#] Progress Columns & Find @ ZoomIn (2 Zoom Out 4 F
A Aerts Delete
B4 Mailbox il Indent
May 5, 2019 May 12, 2019
Task Manager jg  Outdent PG Activity .. | Start date Finish date
e fellefwfvlu]s=]e]
o Information Copy
— ~ -
M Document Manage ! Cut @ Open [ Audit Log
2 I PE Columns
Fi ial Transacti
@ inanciat tran 1 Name Order  Display Mode  Data Source
@ Change Managemd PE I'P6 Activity Number 1 Show UsmACtivNmbrTB120
Start date 2 Show uuu_start
5 3 5 4 Copy Column Data PE —
& Financial Reporting Finish date 3 Show uuu_finish
] 5 Baseline PE || Actual Start Date 4 Show uuu_actual_start_date
3 Linked Business Process  » - Actual Finish Date 5 Show uuu_actual_finish_date,
(@) Schedule Manager - Activity Percent 6 Show uuu_act_pct_complete
Schedule Sheet- I Comments Duration 7 Show uuu_duration
Activity Sheet 8  Update >| |oE
Communication & 9 30% Design Engineering DE
Ongoing Reporting ] 60% Design Engineering DE
Project Closeout 1 90% Design Engineering DE
Move Up (Left Move Down (Right]
Reports 12 Final Review and Approval of De... |DE s | (R I
13 Design Engineering Complete DE &I

Select Your Column Data Source from the Dropdown Menu > Set the Column Position After > All
columns in the Screen Shot > when finished click OK

B Ada + 3 Dele

te 8 indent [§ Outdent antt

=

& demounifier.mimprojectservices.com
[ New (& Open Audit Log
Columns
Name Order  Display Mode  Data Source
Activity Number 1 Show USMACIVNMDI T 5120
Start date 2 Show uuuy_start
Finish date 3 Show uwuu_finish
Actual Start Date 4 Show uuu_actual_start_date
Actual Fiesh Date 5 Show wuu_actual_feush_date
Activity Percent i) Show uwuu_act_pct_complete
Duration 7 Show uuu_duration
Move Up (Lef) | Move Down (Right) |
Close
ee and Apgeoval of O | DE-2040 110272020
DE-2050 1272502020
09/07/2020
080772020
RW-3010 09/07/2020

12721

DRMcNatty
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Name
Progress m] Columns

Data Source:
Data Entry
Entry Method

Data Format

Activity Latest Progress As Of
Activity Percent
Activity Status

cluall
Actual Start Date
Assigned Resources
Auto-update Activity Data
Basekne Duration
Baselne Finish

Baselne Start
Show as percentage Baseline Total Cost
Decimal Places. Calendar
s Early finish date
vy Early Start date
Desplay Earned Amount
Earned Progress
Date rollup Estimated Duration -
Number rollup * Total
Average
Neighted Average based on
: B
Additional
. T
12252020 Display Mode ®  Show Hide
12/25/2020 I Column Position After Activity Name A I
09/032021
0910772020
12/25/2020

2021
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When you return to the Schedule Sheet, you will now see your columns mapped to P6 data in your
Unifier Schedule Sheet.

R

Kansas Avenue Grade. ..

ompany Work.

File

Edit  View

save [EJAdd ~ 9¢Delete [ Indent [F Outdent

| Gantt [ # Progress [fl] Columns @ Find @ ZoomIn (= Zoom Out 4 Focus Close Window I

Alerts

Kansas P6 Schedule

Mailbox (<3)
@

Task Manager

Information &3]

Document Manager &

Financial Transactions

Change Management

Financial Reporting &P

Document Managem... &

O SRR B < B B E

Schedule Manager &

Schedule Sheets

Activity Sheet

Communication & Fo... D

3 Ongoing Reporting @

Project Closeout (53]

Reports &)

Summary

Id Activity Name P6 Activity Number Start date Finish date Actual Start Date | Actual Finish Date | Activity Percent Duration \
1 [=)-Planning_and Environmental 05/15/2019 05/15/2020 367
2 Begin Planning & Environmental PE-1000 05/15/2019 05/15/2019 0‘ 1
3 Environmental Impact Study. PE-1010 05/24/2019 09/13/2019 0 81
4 Draft EIS/EIR PE-1020 09/09/2019 01/31/2020 0 105
5 Review / Approve Final EIS/EIR PE-1030 01/27/2020 05/15/2020 0 80
6 Planning and Environmental Com...| PE-1040 05/15/2020 05/15/2020 0 1
7  |E-Design Engineering . 05/18/2020 12/25/2020 . 222
8 Begin Design Engineering [0 2000 05/18/2020 05/18/2020 o| 1
9 30% Design Engineering DE-2010 05/22/2020 07/17/12020 0 41
10 60% Design Engineering DE-2020 07/13/2020 09/04/2020 0 40
" 90% Design Engineering DE-2030 09/07/2020 10/30/2020 0 40
12 Final Review and Approval of De... | DE-2040 11/02/2020 12/25/2020 0 40
13 Design Engineering Complete .DE—2050 12/25/2020 12/25/2020 0. 1
14  [E-Right of Way, 09/07/2020 09/03/2021 362
15 Begin Right of Way procurement RW-3000 09/07/2020 09/07/2020 0 1
16 Establish ROW RW-3010 09/07/2020 12/25/2020 0 80

Using Unifier’s out-of-the-box built in integration to P6 is one of the most efficient ways to manage
and provide schedule visibility to users working in Unifier projects with P6 schedule
components/needs. Schedule data being updated in P6 can be transferred to Unifier as long as you
understand some of the aspects of its use and how it impacts your projects.
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